www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-ros / camera_info_manager / camera_info_manager-1.11.10.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/image_common"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8
9 inherit ros-catkin
10
11 DESCRIPTION="C++ interface for camera calibration information"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/camera_calibration_parsers
18         dev-ros/image_transport
19         dev-ros/roscpp
20         dev-ros/roslib
21         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
22         dev-libs/boost:=
23 "
24 DEPEND="${RDEPEND} test? ( dev-ros/rostest )"