dev-ros/genpy: bump to 0.6.11
[gentoo.git] / dev-ros / bondcpp / bondcpp-1.8.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/bond_core"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8
9 inherit ros-catkin
10
11 DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/bond
18         dev-ros/cmake_modules
19         >=dev-ros/roscpp-1.13.6
20         dev-ros/smclib
21         dev-libs/boost:=
22         sys-apps/util-linux
23 "
24 DEPEND="${RDEPEND}"