dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ros / ament_cmake_test / ament_cmake_test-0.8.1.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{3_6,3_7} )
7
8 inherit cmake-utils python-r1
9
10 ROS_PN="ament_cmake"
11 if [ "${PV#9999}" != "${PV}" ] ; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/ament/ament_cmake"
14         SRC_URI=""
15         S=${WORKDIR}/${P}/${PN}
16 else
17         SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
18         S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
19 fi
20
21 DESCRIPTION="The ability to add tests in the ament buildsystem"
22 HOMEPAGE="https://github.com/ament/ament_cmake"
23
24 LICENSE="Apache-2.0"
25 SLOT="0"
26 if [ "${PV#9999}" != "${PV}" ] ; then
27         KEYWORDS=""
28 else
29         KEYWORDS="~amd64"
30 fi
31 IUSE=""
32
33 DEPEND="
34         dev-ros/ament_cmake_core
35                 dev-python/ament_package[${PYTHON_USEDEP}]
36                 dev-python/catkin_pkg[${PYTHON_USEDEP}]
37         dev-ros/ament_cmake_python
38         ${PYTHON_DEPS}
39 "
40 RDEPEND="${DEPEND}"
41 BDEPEND="${DEPEND}"
42 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
43
44 src_configure() {
45         python_foreach_impl cmake-utils_src_configure
46 }
47
48 src_compile() {
49         python_foreach_impl cmake-utils_src_compile
50 }
51
52 src_test() {
53         python_foreach_impl cmake-utils_src_test
54 }
55
56 src_install() {
57         python_foreach_impl cmake-utils_src_install
58         python_foreach_impl python_optimize
59 }