dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-ros / ament_cmake_export_libraries / ament_cmake_export_libraries-0.8.1.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{3_6,3_7} )
7
8 inherit cmake-utils python-any-r1
9
10 ROS_PN="ament_cmake"
11 if [ "${PV#9999}" != "${PV}" ] ; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/ament/ament_cmake"
14         SRC_URI=""
15         S=${WORKDIR}/${P}/${PN}
16 else
17         SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
18         S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
19 fi
20
21 DESCRIPTION="Export libraries to downstream packages in the ament buildsystem"
22 HOMEPAGE="https://github.com/ament/ament_cmake"
23
24 LICENSE="Apache-2.0"
25 SLOT="0"
26 if [ "${PV#9999}" != "${PV}" ] ; then
27         KEYWORDS=""
28 else
29         KEYWORDS="~amd64"
30 fi
31 IUSE=""
32
33 RDEPEND="
34         dev-ros/ament_cmake_core
35 "
36 DEPEND="${RDEPEND}"
37 # Deps here are transitive from ament_cmake_core to have matching python support
38 BDEPEND="
39         $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
40         ${PYTHON_DEPS}
41 "
42
43 python_check_deps() {
44         has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
45                 has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
46 }