sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-ros / actionlib / actionlib-1.11.15.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 CATKIN_HAS_MESSAGES=yes
6 ROS_REPO_URI="https://github.com/ros/actionlib"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
9 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
10
11 inherit ros-catkin
12
13 DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="dev-libs/boost:=[threads]
19         dev-ros/roscpp
20         dev-ros/rospy[${PYTHON_USEDEP}]
21         "
22 DEPEND="${RDEPEND}
23         dev-ros/rosunit[${PYTHON_USEDEP}]
24         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
25 RDEPEND="${RDEPEND}
26         dev-ros/roslib[${PYTHON_USEDEP}]
27         dev-ros/rostopic[${PYTHON_USEDEP}]
28 "