10fcbb0e991fa219eac0d01833636550236aad52
[gentoo.git] / dev-qt / qtxml / qtxml-5.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 QT5_MODULE="qtbase"
7 inherit qt5-build
8
9 DESCRIPTION="SAX and DOM implementation library for the Qt5 framework"
10
11 if [[ ${QT5_BUILD_TYPE} == release ]]; then
12         KEYWORDS="amd64 arm ~arm64 hppa ppc64 ~x86"
13 fi
14
15 IUSE=""
16
17 RDEPEND="
18         ~dev-qt/qtcore-${PV}
19 "
20 DEPEND="${RDEPEND}
21         test? ( ~dev-qt/qtnetwork-${PV} )
22 "
23
24 QT5_TARGET_SUBDIRS=(
25         src/xml
26 )