dev-qt: Add Qt 5.12.2
[gentoo.git] / dev-qt / qtx11extras / qtx11extras-5.12.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit qt5-build
6
7 DESCRIPTION="Linux/X11-specific support library for the Qt5 framework"
8
9 if [[ ${QT5_BUILD_TYPE} == release ]]; then
10         KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
11 fi
12
13 IUSE=""
14
15 RDEPEND="
16         ~dev-qt/qtcore-${PV}
17         ~dev-qt/qtgui-${PV}[xcb]
18 "
19 DEPEND="${RDEPEND}
20         test? ( ~dev-qt/qtwidgets-${PV} )
21 "