games-util/joystick: Bump to version 1.4.9
[gentoo.git] / dev-qt / qtwidgets / qtwidgets-5.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 QT5_MODULE="qtbase"
7 inherit qt5-build
8
9 DESCRIPTION="Set of components for creating classic desktop-style UIs for the Qt5 framework"
10
11 if [[ ${QT5_BUILD_TYPE} == release ]]; then
12         KEYWORDS="amd64 arm ~arm64 hppa ppc64 ~x86"
13 fi
14
15 # keep IUSE defaults in sync with qtgui
16 IUSE="gles2 gtkstyle +png +xcb"
17
18 DEPEND="
19         ~dev-qt/qtcore-${PV}
20         ~dev-qt/qtgui-${PV}[gles2=,gtkstyle=,png=,xcb?]
21 "
22 RDEPEND="${DEPEND}"
23
24 QT5_TARGET_SUBDIRS=(
25         src/tools/uic
26         src/widgets
27 )
28
29 QT5_GENTOO_CONFIG=(
30         !:no-widgets:
31 )
32
33 src_configure() {
34         local myconf=(
35                 $(qt_use gtkstyle)
36                 -opengl $(usex gles2 es2 desktop)
37                 $(qt_use png libpng system)
38                 $(qt_use xcb xcb system)
39                 $(qt_use xcb xkbcommon system)
40                 $(use xcb && echo -xcb-xlib -xinput2 -xkb -xrender)
41         )
42         qt5-build_src_configure
43 }