dev-ruby/ruby-beautify: document ruby25 status
[gentoo.git] / dev-qt / qtwebsockets / qtwebsockets-5.9.4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit qt5-build
6
7 DESCRIPTION="Implementation of the WebSocket protocol for the Qt5 framework"
8
9 if [[ ${QT5_BUILD_TYPE} == release ]]; then
10         KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc64 x86"
11 fi
12
13 IUSE="qml +ssl"
14
15 DEPEND="
16         ~dev-qt/qtcore-${PV}
17         ~dev-qt/qtnetwork-${PV}[ssl=]
18         qml? ( ~dev-qt/qtdeclarative-${PV} )
19
20 "
21 RDEPEND="${DEPEND}"
22
23 src_prepare() {
24         qt_use_disable_mod qml quick src/src.pro
25
26         qt5-build_src_prepare
27 }