sys-libs/readline: stable 8.0_p4 for hppa, bug #719942
[gentoo.git] / dev-qt / qtwebchannel / qtwebchannel-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit qt5-build
6
7 DESCRIPTION="Qt5 module for integrating C++ and QML applications with HTML/JavaScript clients"
8
9 if [[ ${QT5_BUILD_TYPE} == release ]]; then
10         KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
11 fi
12
13 IUSE="qml"
14
15 DEPEND="
16         ~dev-qt/qtcore-${PV}
17         qml? ( ~dev-qt/qtdeclarative-${PV} )
18 "
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         qt_use_disable_mod qml quick src/src.pro
23         qt_use_disable_mod qml qml src/webchannel/webchannel.pro
24
25         qt5-build_src_prepare
26 }