dev-qt: version bump 5.9.3
[gentoo.git] / dev-qt / qtwayland / qtwayland-5.9.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit qt5-build
6
7 DESCRIPTION="Wayland platform plugin for Qt"
8
9 if [[ ${QT5_BUILD_TYPE} == release ]]; then
10         KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
11 fi
12
13 IUSE="+libinput xcomposite"
14
15 DEPEND="
16         >=dev-libs/wayland-1.6.0
17         ~dev-qt/qtcore-${PV}
18         ~dev-qt/qtdeclarative-${PV}
19         ~dev-qt/qtgui-${PV}[egl,libinput?]
20         media-libs/mesa[egl]
21         >=x11-libs/libxkbcommon-0.2.0
22         xcomposite? (
23                 x11-libs/libX11
24                 x11-libs/libXcomposite
25         )
26 "
27 RDEPEND="${DEPEND}"
28
29 src_prepare() {
30         qt_use_disable_config libinput xkbcommon-evdev \
31                 src/client/client.pro \
32                 src/compositor/wayland_wrapper/wayland_wrapper.pri \
33                 src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
34                 tests/auto/compositor/compositor/compositor.pro
35
36         use xcomposite || rm -r config.tests/xcomposite || die
37
38         qt5-build_src_prepare
39 }