games-util/joystick: Bump to version 1.4.9
[gentoo.git] / dev-qt / qtwayland / qtwayland-5.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit qt5-build
7
8 DESCRIPTION="Wayland platform plugin for Qt"
9
10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
11         KEYWORDS="amd64 arm ~hppa ~ppc64 ~x86"
12 fi
13
14 IUSE="egl qml wayland-compositor xcomposite"
15
16 DEPEND="
17         >=dev-libs/wayland-1.3.0
18         >=dev-qt/qtcore-${PV}:5
19         >=dev-qt/qtgui-${PV}:5[egl=]
20         media-libs/mesa[egl?]
21         >=x11-libs/libxkbcommon-0.2.0
22         qml? ( >=dev-qt/qtdeclarative-${PV}:5 )
23         xcomposite? (
24                 x11-libs/libX11
25                 x11-libs/libXcomposite
26         )
27 "
28 RDEPEND="${DEPEND}"
29
30 src_configure() {
31         if use wayland-compositor; then
32                 echo "CONFIG += wayland-compositor" >> "${QT5_BUILD_DIR}"/.qmake.cache
33         fi
34
35         qt_use_compile_test xcomposite
36
37         qt5-build_src_configure
38 }