eadbc9f31c231a6fc376cc442d3b647415a7f82b
[gentoo.git] / dev-qt / qtopengl / qtopengl-5.12.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 QT5_MODULE="qtbase"
6 VIRTUALX_REQUIRED="test"
7 inherit qt5-build
8
9 DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
10
11 if [[ ${QT5_BUILD_TYPE} == release ]]; then
12         KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-fbsd"
13 fi
14
15 IUSE="gles2"
16
17 DEPEND="
18         ~dev-qt/qtcore-${PV}
19         ~dev-qt/qtgui-${PV}[gles2=]
20         ~dev-qt/qtwidgets-${PV}[gles2=]
21         virtual/opengl
22 "
23 RDEPEND="${DEPEND}"
24
25 QT5_TARGET_SUBDIRS=(
26         src/opengl
27 )
28
29 src_configure() {
30         local myconf=(
31                 -opengl $(usex gles2 es2 desktop)
32         )
33         qt5-build_src_configure
34 }