dev-util/ctags: Merge "add a snapshot ebuild"
[gentoo.git] / dev-qt / qtmultimedia / qtmultimedia-4.8.7.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit qt4-build-multilib
7
8 DESCRIPTION="The Multimedia module for the Qt toolkit"
9
10 if [[ ${QT4_BUILD_TYPE} == release ]]; then
11         KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
12 fi
13
14 IUSE="alsa"
15
16 DEPEND="
17         ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
18         ~dev-qt/qtgui-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
19         alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
20 "
21 RDEPEND="${DEPEND}"
22
23 PATCHES=(
24         "${FILESDIR}/${PN}-4.8.0-alsa.patch"
25 )
26
27 QT4_TARGET_DIRECTORIES="src/multimedia"
28
29 QCONFIG_ADD="multimedia"
30 QCONFIG_DEFINE="QT_MULTIMEDIA"
31
32 multilib_src_configure() {
33         local myconf=(
34                 -multimedia -audio-backend
35                 $(qt_use alsa)
36                 -no-accessibility -no-qt3support -no-xmlpatterns -no-phonon -no-phonon-backend
37                 -no-svg -no-webkit -no-script -no-scripttools -no-declarative
38                 -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg -no-openssl
39                 -no-cups -no-dbus -no-gtkstyle -no-nas-sound -no-opengl
40                 -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes
41                 -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb
42         )
43         qt4_multilib_src_configure
44 }