dev-python/click-default-group: keyworded 1.2.2 for ia64, bug #700918
[gentoo.git] / dev-qt / qtlocation / qtlocation-5.14.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit qt5-build
6
7 DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
8
9 if [[ ${QT5_BUILD_TYPE} == release ]]; then
10         KEYWORDS="amd64 ~arm arm64 x86"
11 fi
12
13 IUSE=""
14
15 RDEPEND="
16         ~dev-qt/qtcore-${PV}
17         ~dev-qt/qtdeclarative-${PV}
18         ~dev-qt/qtgui-${PV}
19         ~dev-qt/qtnetwork-${PV}
20         ~dev-qt/qtpositioning-${PV}[qml]
21         ~dev-qt/qtsql-${PV}
22         sys-libs/zlib
23 "
24 DEPEND="${RDEPEND}
25         ~dev-qt/qtconcurrent-${PV}
26 "
27
28 QT5_TARGET_SUBDIRS=(
29         src/3rdparty/clipper
30         src/3rdparty/poly2tri
31         src/3rdparty/clip2tri
32         src/3rdparty/mapbox-gl-native
33         src/location
34         src/imports/location
35         src/imports/locationlabs
36         src/plugins/geoservices
37 )
38
39 src_configure() {
40         # src/plugins/geoservices requires files that are only generated when
41         # qmake is run in the root directory. Bug 633776.
42         mkdir -p "${QT5_BUILD_DIR}" || die
43         qt5_qmake "${QT_BUILD_DIR}"
44         qt5-build_src_configure
45 }