dev-python/Babel: Drop old
[gentoo.git] / dev-qt / qtgraphicaleffects / qtgraphicaleffects-5.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit qt5-build virtualx
7
8 DESCRIPTION="Set of QML types for adding visual effects to user interfaces"
9
10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
11         KEYWORDS="amd64 arm ~hppa ~ppc64 ~x86"
12 fi
13
14 IUSE=""
15
16 RDEPEND="
17         >=dev-qt/qtcore-${PV}:5
18         >=dev-qt/qtdeclarative-${PV}:5
19         >=dev-qt/qtxmlpatterns-${PV}:5
20 "
21 DEPEND="${RDEPEND}
22         test? ( >=dev-qt/qtgui-${PV}:5 )
23 "
24
25 src_test() {
26         local VIRTUALX_COMMAND="qt5-build_src_test"
27         virtualmake
28 }