6685023e43de55be8ddff0c54e6c9a64e36d9a90
[gentoo.git] / dev-qt / qtcore / qtcore-5.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 QT5_MODULE="qtbase"
7 inherit qt5-build
8
9 DESCRIPTION="Cross-platform application development framework"
10
11 if [[ ${QT5_BUILD_TYPE} == release ]]; then
12         KEYWORDS="amd64 arm ~arm64 hppa ppc64 ~x86"
13 fi
14
15 IUSE="icu systemd"
16
17 DEPEND="
18         dev-libs/glib:2
19         >=dev-libs/libpcre-8.35[pcre16]
20         >=sys-libs/zlib-1.2.5
21         virtual/libiconv
22         icu? ( dev-libs/icu:= )
23         systemd? ( sys-apps/systemd )
24 "
25 RDEPEND="${DEPEND}"
26
27 QT5_TARGET_SUBDIRS=(
28         src/tools/bootstrap
29         src/tools/moc
30         src/tools/rcc
31         src/corelib
32         src/tools/qlalr
33 )
34
35 src_configure() {
36         local myconf=(
37                 $(qt_use icu)
38                 $(qt_use systemd journald)
39         )
40         qt5-build_src_configure
41 }