dev-qt: Add Qt 5.11.0_rc2
[gentoo.git] / dev-qt / qtconcurrent / qtconcurrent-5.11.0_rc2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 QT5_MODULE="qtbase"
6 inherit qt5-build
7
8 DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
9
10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
11         KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
12 fi
13
14 IUSE=""
15
16 DEPEND="
17         ~dev-qt/qtcore-${PV}
18 "
19 RDEPEND="${DEPEND}"
20
21 QT5_TARGET_SUBDIRS=(
22         src/concurrent
23 )