dev-python/dj-database-url: Version Bump
[gentoo.git] / dev-qt / qt-docs / qt-docs-5.7.1_p0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit versionator
7
8 MY_PV=$(get_version_component_range 1)$(get_version_component_range 2)
9 MY_P=${PV/_p/-}qt-everywhere-documentation-${PV%%_p*}
10
11 DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other tools"
12 HOMEPAGE="https://www.qt.io/"
13 SRC_URI="https://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${MY_P}.7z"
14
15 LICENSE="FDL-1.3"
16 SLOT="5"
17 KEYWORDS="~amd64 ~x86"
18
19 DEPEND="app-arch/p7zip"
20
21 S=${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)
22
23 src_prepare() {
24         default
25
26         # bug 597026
27         rm -r global || die
28
29         # bug 602750
30         rm Makefile || die
31 }
32
33 src_install() {
34         # ${PV} instead of ${PF} is intentional
35         local dest=/usr/share/doc/qt-${PV%%_p*}
36         insinto "${dest}"
37         doins -r *
38         docompress -x "${dest}"
39 }