games-util/joystick: Bump to version 1.4.9
[gentoo.git] / dev-qt / qt-docs / qt-docs-5.4.2_p0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit versionator
8
9 MY_PV=$(get_version_component_range 1)$(get_version_component_range 2)
10
11 DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other tools"
12 HOMEPAGE="https://www.qt.io/"
13 SRC_URI="http://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${PV/_p/-}qt5_docs.7z"
14
15 LICENSE="FDL-1.3"
16 SLOT="5"
17 KEYWORDS="~amd64 ~x86"
18
19 DEPEND="app-arch/p7zip"
20
21 S=${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)
22
23 src_install() {
24         # remove global docs that conflict with qtcore
25         rm -rf global
26
27         # ${PV} instead of ${PF} is intentional
28         local dest=/usr/share/doc/qt-${PV%%_p*}
29         insinto "${dest}"
30         doins -r *
31         docompress -x "${dest}"
32 }