dev-qt/qtwidgets: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-qt / qt-docs / qt-docs-5.14.1_p202001241012.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PV_FULL=${PV/_p/-0-}
7 PV_NODOTS=$(ver_rs 1-3 '' ${PV%_p*})
8 BASE_URI="https://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${PV_NODOTS}_src_doc_examples/qt.qt5.${PV_NODOTS}.doc"
9
10 declare -A QT5_DOCS=(
11         [3d]="qt3d"
12         [assistant]="qtassistant"
13         [bluetooth]="qtbluetooth"
14         [concurrent]="qtconcurrent"
15         [core]="qtcore qmake qtdoc"
16         [dbus]="qtdbus"
17         [declarative]="qtqml qtqmltest qtquick qtquickdialogs qtquickextras"
18         [designer]="qtdesigner qtuitools"
19         [gamepad]="qtgamepad"
20         [graphicaleffects]="qtgraphicaleffects"
21         [gui]="qtgui qtplatformheaders"
22         [help]="qthelp"
23         [imageformats]="qtimageformats"
24         [linguist]="qtlinguist"
25         [location]="qtlocation"
26         [multimedia]="qtmultimedia"
27         [network]="qtnetwork"
28         [opengl]="qtopengl"
29         [positioning]="qtpositioning"
30         [printsupport]="qtprintsupport"
31         [qdoc]="qdoc"
32         [quickcontrols2]="qtquickcontrols"
33         [quickcontrols]="qtquickcontrols1"
34         [scxml]="qtscxml"
35         [sensors]="qtsensors"
36         [serialbus]="qtserialbus"
37         [serialport]="qtserialport"
38         [speech]="qtspeech"
39         [sql]="qtsql"
40         [svg]="qtsvg"
41         [test]="qttestlib"
42         [wayland]="qtwaylandcompositor"
43         [webchannel]="qtwebchannel"
44         [websockets]="qtwebsockets"
45         [webview]="qtwebview"
46         [widgets]="qtwidgets"
47         [x11extras]="qtx11extras"
48         [xml]="qtxml"
49         [xmlpatterns]="qtxmlpatterns"
50 )
51
52 DESCRIPTION="Qt5 documentation, for use with Qt Creator and other tools"
53 HOMEPAGE="https://doc.qt.io/"
54
55 LICENSE="FDL-1.3"
56 SLOT="5"
57 KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
58
59 IUSE="charts datavis +html networkauth +qch script virtualkeyboard webengine"
60 REQUIRED_USE="|| ( html qch )"
61
62 SRC_URI="
63         charts? ( ${BASE_URI}.qtcharts/${PV_FULL}qtcharts-documentation.7z )
64         datavis? ( ${BASE_URI}.qtdatavis3d/${PV_FULL}qtdatavisualization-documentation.7z )
65         networkauth? ( ${BASE_URI}.qtnetworkauth/${PV_FULL}qtnetworkauth-documentation.7z )
66         script? ( ${BASE_URI}.qtscript/${PV_FULL}qtscript-documentation.7z
67                 ${BASE_URI}.qtscript/${PV_FULL}qtscripttools-documentation.7z )
68         virtualkeyboard? ( ${BASE_URI}.qtvirtualkeyboard/${PV_FULL}qtvirtualkeyboard-documentation.7z )
69         webengine? ( ${BASE_URI}.qtwebengine/${PV_FULL}qtwebengine-documentation.7z )
70 "
71
72 for DOCUSE in ${!QT5_DOCS[@]}; do
73         IUSE+=" +${DOCUSE}"
74         for DOCTAR in ${QT5_DOCS[${DOCUSE}]}; do
75                 SRC_URI+=" ${DOCUSE}? ( ${BASE_URI}/${PV_FULL}${DOCTAR}-documentation.7z )"
76         done
77 done
78 unset DOCTAR DOCUSE
79
80 BDEPEND="app-arch/p7zip"
81
82 S=${WORKDIR}/Docs/Qt-${PV%_p*}
83
84 src_install() {
85         # must be the same as QT5_DOCDIR
86         insinto /usr/share/qt5-doc
87         use html && doins -r */
88         use qch && doins *.qch
89 }