25b6f2ea326d0da49402b3122667ae513a944ec7
[gentoo.git] / dev-qt / linguist-tools / linguist-tools-5.12.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 QT5_MODULE="qttools"
6 inherit qt5-build
7
8 DESCRIPTION="Tools for working with Qt translation data files"
9
10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
11         KEYWORDS="arm x86"
12 fi
13
14 IUSE="qml"
15
16 DEPEND="
17         ~dev-qt/qtcore-${PV}
18         ~dev-qt/qtxml-${PV}
19         qml? ( ~dev-qt/qtdeclarative-${PV} )
20 "
21 RDEPEND="${DEPEND}"
22
23 QT5_TARGET_SUBDIRS=(
24         src/linguist
25 )
26
27 src_prepare() {
28         sed -i -e '/SUBDIRS += linguist/d' \
29                 src/linguist/linguist.pro || die
30
31         qt_use_disable_mod qml qmldevtools-private \
32                 src/linguist/lupdate/lupdate.pro
33
34         qt5-build_src_prepare
35 }