dev-qt: Drop Qt 5.11.0_rc (1)
[gentoo.git] / dev-qt / assistant / assistant-4.8.7.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils qt4-build-multilib
6
7 DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
8
9 if [[ ${QT4_BUILD_TYPE} == release ]]; then
10         KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
11 fi
12
13 IUSE="webkit"
14
15 DEPEND="
16         ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
17         ~dev-qt/qtgui-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
18         ~dev-qt/qthelp-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
19         ~dev-qt/qtsql-${PV}[aqua=,debug=,sqlite,${MULTILIB_USEDEP}]
20         webkit? ( ~dev-qt/qtwebkit-${PV}[aqua=,debug=,${MULTILIB_USEDEP}] )
21 "
22 RDEPEND="${DEPEND}"
23
24 PATCHES=(
25         "${FILESDIR}/${PN}-4.8.2+gcc-4.7.patch"
26 )
27
28 QT4_TARGET_DIRECTORIES="tools/assistant/tools/assistant"
29
30 src_prepare() {
31         # bug 401173
32         use webkit || PATCHES+=("${FILESDIR}/disable-webkit.patch")
33
34         qt4-build-multilib_src_prepare
35 }
36
37 multilib_src_configure() {
38         local myconf=(
39                 -system-libpng -system-libjpeg -system-zlib
40                 -no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite2 -no-sql-odbc
41                 -sm -xshape -xsync -xcursor -xfixes -xrandr -xrender -mitshm -xinput -xkb
42                 -fontconfig -no-multimedia -no-opengl -no-phonon -no-svg -no-xmlpatterns
43                 $(qt_use webkit)
44         )
45         qt4_multilib_src_configure
46 }
47
48 multilib_src_install_all() {
49         qt4_multilib_src_install_all
50
51         doicon tools/assistant/tools/assistant/images/assistant.png
52         make_desktop_entry assistant Assistant assistant 'Qt;Development;Documentation'
53 }