Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-python / zope-interface / zope-interface-4.3.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
7
8 inherit distutils-r1 flag-o-matic
9
10 MY_PN=${PN/-/.}
11 MY_P=${MY_PN}-${PV}
12
13 DESCRIPTION="Interfaces for Python"
14 HOMEPAGE="https://pypi.python.org/pypi/zope.interface https://github.com/zopefoundation/zope.interface"
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="ZPL"
18 SLOT="0"
19 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
20 IUSE="test"
21
22 RDEPEND=""
23 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
24         test? ( dev-python/zope-event[${PYTHON_USEDEP}] )"
25
26 S=${WORKDIR}/${MY_P}
27
28 python_compile() {
29         if ! python_is_python3; then
30                 local CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
31                 append-flags -fno-strict-aliasing
32         fi
33
34         distutils-r1_python_compile
35 }
36
37 python_test() {
38         esetup.py test
39 }