profiles/arch/amd64-fbsd/todo: force pulseaudio on firefox, bug 562412
[gentoo.git] / dev-python / zope-interface / zope-interface-4.1.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1 flag-o-matic
9
10 MY_PN=${PN/-/.}
11 MY_P=${MY_PN}-${PV}
12
13 DESCRIPTION="Interfaces for Python"
14 HOMEPAGE="https://pypi.python.org/pypi/zope.interface"
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="ZPL"
18 SLOT="0"
19 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
20 IUSE=""
21
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
23 RDEPEND=""
24
25 S=${WORKDIR}/${MY_P}
26
27 # until all deps are in the tree (bug #442794)
28 RESTRICT="test"
29
30 python_compile() {
31         if [[ ${EPYTHON} != python3* ]]; then
32                 local CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
33                 append-flags -fno-strict-aliasing
34         fi
35
36         distutils-r1_python_compile
37 }
38
39 python_test() {
40         esetup.py test
41 }