dev-python/click-default-group: keyworded 1.2.2 for ia64, bug #700918
[gentoo.git] / dev-python / zeroconf / zeroconf-0.24.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
10 HOMEPAGE="https://github.com/jstasiak/python-zeroconf https://pypi.org/project/zeroconf/"
11 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
16 IUSE="test"
17
18 RDEPEND="dev-python/ifaddr[${PYTHON_USEDEP}]"
19 DEPEND="${RDEPEND}
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         test? (
22                 dev-python/nose[${PYTHON_USEDEP}]
23         )"
24
25 # Not included
26 RESTRICT="test"
27
28 python_prepare_all() {
29         # It's virtual/python-enum34
30         sed \
31                 -e "s:'enum-compat',::g" \
32                 -i setup.py || die
33         distutils-r1_python_prepare_all
34 }
35
36 python_test() {
37         nosetests --verbose || die
38 }