dev-python/sunpy: use HTTPS
[gentoo.git] / dev-python / yarl / yarl-1.2.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_{4,5,6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Yet another URL library"
10 HOMEPAGE="https://github.com/aio-libs/yarl/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 RDEPEND="
19         >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
20         >=dev-python/idna-2.0[${PYTHON_USEDEP}]
21 "
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 dev-python/pytest[${PYTHON_USEDEP}]
26                 dev-python/pytest-runner[${PYTHON_USEDEP}]
27         )"
28
29 python_test() {
30         esetup.py test
31 }