e5279a984a0825dd8938e20252f09d241b1a3d6c
[gentoo.git] / dev-python / yappi / yappi-0.98.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=(python{2_7,3_{5,6}})
6 inherit distutils-r1
7
8 DESCRIPTION="Yet Another Python Profiler"
9 HOMEPAGE="https://bitbucket.org/sumerc/yappi/"
10 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 DEPEND="${RDEPEND}
20         test? ( dev-python/nose[${PYTHON_USEDEP}] )"
21
22 python_test() {
23         esetup.py test
24 }