dev-python/pygsl: amd64 stable wrt bug #574720
[gentoo.git] / dev-python / xvfbwrapper / xvfbwrapper-0.2.8.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python wrapper for running a display inside X virtual framebuffer"
11 HOMEPAGE="https://github.com/cgoldberg/xvfbwrapper
12         https://pypi.python.org/pypi/xvfbwrapper"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19
20 RDEPEND="x11-base/xorg-server[xvfb]"
21 DEPEND="${RDEPEND}
22         test? ( dev-python/pep8[${PYTHON_USEDEP}] )
23 "
24
25 python_test() {
26 #       "${PYTHON}" test_xvfb.py || die "Tests failed with ${EPYTHON}"
27         "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
28 }