Merge remote-tracking branch 'github/pr/108'
[gentoo.git] / dev-python / xmpppy / xmpppy-0.5.0_rc1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="3"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit distutils eutils
11
12 MY_P="${P/_/-}"
13
14 DESCRIPTION="Python library providing easy scripting with Jabber"
15 HOMEPAGE="http://xmpppy.sourceforge.net/"
16 SRC_URI="mirror://sourceforge/xmpppy/${MY_P}.tar.gz"
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
21 IUSE="doc"
22
23 RDEPEND="|| (
24                 dev-python/dnspython
25                 dev-python/pydns
26         )"
27 DEPEND="${RDEPEND}
28         dev-python/setuptools"
29
30 S="${WORKDIR}/${MY_P}"
31
32 PYTHON_MODNAME="xmpp"
33
34 src_prepare() {
35         distutils_src_prepare
36         epatch "${FILESDIR}/${PN}-hashlib_ssl_deprecation.patch"
37 }
38
39 src_install() {
40         distutils_src_install
41         use doc && dohtml -A py -r doc/.
42 }