d50684ae43a111376f801213e80b7fa622de4d7b
[gentoo.git] / dev-python / weasyprint / weasyprint-43.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
11 MY_PN="WeasyPrint"
12 MY_P="${MY_PN}-${PV}"
13 SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
14 HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="jpeg test tiff"
20 RESTRICT="!test? ( test )"
21
22 # Note: specific subslot of pango since it inlines some of pango headers.
23 RDEPEND="
24         >=x11-libs/cairo-1.15.4
25         x11-libs/gdk-pixbuf[jpeg?,tiff?]
26         x11-libs/pango:0/0
27         >=dev-python/cairocffi-0.9[${PYTHON_USEDEP}]
28         >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
29         >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
30         >=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]
31         >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
32         >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]
33         >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
34         >=media-gfx/cairosvg-1.0.20[${PYTHON_USEDEP}]
35 "
36 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
37         test? (
38                 ${RDEPEND}
39                 dev-python/pytest[${PYTHON_USEDEP}]
40                 media-fonts/ahem
41         )
42 "
43
44 PATCHES=(
45         "${FILESDIR}/${PN}-43-skip-useless-deps.patch"
46         "${FILESDIR}/${PN}-43-skip-failing-test.patch"
47 )
48
49 S="${WORKDIR}/${MY_P}"
50
51 python_test() {
52         pytest -vv || die "testsuite failed under ${EPYTHON}"
53 }