net-vpn/networkmanager-pptp: update dep for libnm-gtk
[gentoo.git] / dev-python / wcwidth / wcwidth-0.1.7-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
11 HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=""
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? ( dev-python/pytest[${PYTHON_USEDEP}] )
24 "
25
26 python_test() {
27         py.test -v -rs --strict wcwidth/tests || die
28 }