dev-python/cython: Drop some intermediate Versions, which seem to cause problems
[gentoo.git] / dev-python / watchdog / watchdog-0.8.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4} pypy)
8
9 inherit distutils-r1 eutils
10
11 DESCRIPTION="Python API and shell utilities to monitor file system events"
12 HOMEPAGE="https://github.com/gorakhargosh/watchdog"
13 SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm ~x86"
18 IUSE="test"
19
20 CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
21 RDEPEND="${CDEPEND}
22         dev-python/argh[${PYTHON_USEDEP}]
23         dev-python/pathtools[${PYTHON_USEDEP}]"
24 DEPEND="${CDEPEND}
25         test? (
26                 dev-python/pytest[${PYTHON_USEDEP}]
27                 dev-python/pytest-cov[${PYTHON_USEDEP}]
28                 >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
29                 )"
30
31 python_test() {
32         esetup.py test
33 }
34
35 pkg_postinst() {
36         optfeature "Bash completion" dev-python/argcomplete
37 }