dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / voluptuous / voluptuous-0.11.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A Python data validation library."
10 HOMEPAGE="https://github.com/alecthomas/voluptuous"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND=""
20
21 python_test() {
22         unset PYTHONPATH
23         nosetests -v || die "Tests failed"
24 }