fa6ba2fb1edbad3a78391815b23eb2b697988526
[gentoo.git] / dev-python / virtualenvwrapper / virtualenvwrapper-4.8.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
11 HOMEPAGE="https://bitbucket.org/dhellmann/virtualenvwrapper
12         https://pypi.org/project/virtualenvwrapper/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE="test"
19
20 # testsuite doesn't work out of the box.  Demand of a virtualenv outstrips setup by the eclass
21 RESTRICT=test
22
23 RDEPEND="
24         dev-python/virtualenv[${PYTHON_USEDEP}]
25         dev-python/stevedore[${PYTHON_USEDEP}]
26         dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
27 DEPEND="${DEPEND}
28         dev-python/setuptools[${PYTHON_USEDEP}]
29         dev-python/pbr[${PYTHON_USEDEP}]"
30
31 python_test() {
32         bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
33 }