dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / uvloop / uvloop-0.8.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{3_5,3_6} )
7 inherit distutils-r1
8
9 DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
10 HOMEPAGE="https://github.com/magicstack/uvloop"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12 KEYWORDS="~amd64 ~x86"
13
14 LICENSE="MIT"
15 SLOT="0"
16 IUSE="doc examples test"
17
18 RDEPEND=">=dev-libs/libuv-1.11.0:="
19 DEPEND="
20         ${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         doc? (
23                 >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
24                 dev-python/sphinx[${PYTHON_USEDEP}]
25         )
26 "
27
28 python_prepare_all() {
29         cat <<EOF >> setup.cfg
30 [build_ext]
31 use-system-libuv=1
32 EOF
33
34         distutils-r1_python_prepare_all
35 }
36
37 python_compile_all() {
38         use doc && esetup.py build_ext --inplace build_sphinx
39 }
40
41 python_test() {
42         esetup.py test
43 }
44
45 python_install_all() {
46         use examples && dodoc -r examples
47         use doc && local HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
48         distutils-r1_python_install_all
49 }