dev-python/virtualenv: arm64 keyworded (bug #700918)
[gentoo.git] / dev-python / txaio / txaio-2.9.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Compatibility API between asyncio/Twisted/Trollius"
10 HOMEPAGE="https://github.com/crossbario/txaio https://pypi.org/project/txaio/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
16 IUSE="doc test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         dev-python/six[${PYTHON_USEDEP}]
22         doc? (
23                 >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
24                 >=dev-python/sphinxcontrib-spelling-2.1.2[${PYTHON_USEDEP}]
25                 >=dev-python/sphinx_rtd_theme-0.1.9[${PYTHON_USEDEP}]
26         )
27         test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
28                 >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
29         )
30 "
31
32 src_prepare() {
33         default_src_prepare
34         # Take out failing tests known to pass when run manually
35         # we certainly don't need to test "python setup.py sdist" here
36         rm "${S}/test/test_packaging.py" || die
37 }
38
39 python_compile_all() {
40         use doc && emake -C docs html
41 }
42
43 python_test() {
44         pytest -v || die "Tests failed under ${EPYTHON}"
45 }
46
47 python_install_all() {
48         use doc && HTML_DOCS=( docs/_build/html/. )
49         distutils-r1_python_install_all
50 }