dev-python/trustme: keyworded 0.6.0 for ppc, bug #711762
[gentoo.git] / dev-python / trustme / trustme-0.6.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
7 inherit distutils-r1
8
9 DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
10 HOMEPAGE="https://github.com/python-trio/trustme"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="|| ( Apache-2.0 MIT )"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
16
17 RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
18         dev-python/idna[${PYTHON_USEDEP}]
19         $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' -2 )"
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? (
23                 dev-python/pyopenssl[${PYTHON_USEDEP}]
24                 dev-python/service_identity[${PYTHON_USEDEP}]
25                 $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' -2 )
26         )"
27
28 distutils_enable_tests pytest