dev-python/tldextract: Remove py2
[gentoo.git] / dev-python / tldextract / tldextract-2.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{3_6,3_7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL."
10 HOMEPAGE="https://pypi.org/project/tldextract/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="
19         dev-python/setuptools[${PYTHON_USEDEP}]
20 "
21 RDEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         dev-python/idna[${PYTHON_USEDEP}]
24         dev-python/requests[${PYTHON_USEDEP}]
25         dev-python/requests-file[${PYTHON_USEDEP}]
26 "