dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / tinydb / tinydb-3.1.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{4,5}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Tiny document-oriented database"
11 HOMEPAGE="https://github.com/msiemens/tinydb
12         https://pypi.python.org/pypi/tinydb"
13 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19
20 RDEPEND=""
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/pytest[${PYTHON_USEDEP}]
25         )"
26
27 python_prepare_all() {
28         sed \
29                 -e "s:find_packages():find_packages(exclude=['tests']):g" \
30                 -i setup.py || die
31         distutils-r1_python_prepare_all
32 }
33
34 python_test() {
35         py.test -v -v || die
36 }