Merge remote-tracking branch 'origin/dev-python/dj-database-url'
[wtk-overlay.git] / dev-python / timebook / timebook-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 PYTHON_DEPEND="2:2.7"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit eutils distutils
12
13 if [[ ${PV} == "9999" ]] ; then
14         inherit mercurial
15         EHG_REPO_URI="https://bitbucket.org/trevor/${PN}"
16         SRC_URI=""
17 else
18         SRC_URI=""
19 fi
20
21 DESCRIPTION="Track what you spend time on via this simple command line application"
22 HOMEPAGE="https://bitbucket.org/trevor/${PN}/overview"
23
24 LICENSE="MIT"
25 SLOT="0"
26 KEYWORDS="~x86 ~amd64"
27 IUSE=""
28
29 RDEPEND="dev-lang/python[sqlite]"
30 DEPEND=""
31
32 src_unpack() {
33         if [[ ${PV} == "9999" ]] ; then
34                 mercurial_src_unpack
35         else
36                 unpack ${A}
37         fi
38         cd "${S}"
39 }
40
41 src_install() {
42         distutils_src_install
43         dodoc README
44 }