6a1e86af650522bd4275883dea9c8a1cbcf0ff05
[gentoo.git] / dev-python / testscenarios / testscenarios-0.5.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A pyunit extension for dependency injection"
11 HOMEPAGE="https://launchpad.net/testscenarios"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/testtools[${PYTHON_USEDEP}]"
22
23 # using pytest for tests since unittest loader fails with py3.5+
24 DEPEND="
25         ${RDEPEND}
26         dev-python/setuptools[${PYTHON_USEDEP}]
27         >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
28         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
29
30 python_prepare_all() {
31         # Remove a faulty file from tests, missing a required attribute
32         rm ${PN}/tests/test_testcase.py || die
33         distutils-r1_python_prepare_all
34 }
35
36 python_test() {
37         pytest -vv || die "Tests fail with ${EPYTHON}"
38 }