ee715933d244957d4606387430c7b36f651c2e3b
[gentoo.git] / dev-python / tabulate / tabulate-0.8.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Pretty-print tabular data"
11 HOMEPAGE="https://pypi.org/project/tabulate/ https://github.com/astanin/python-tabulate"
12 SRC_URI="https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 S="${WORKDIR}/python-${P}"
14
15 SLOT="0"
16 LICENSE="MIT"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
22         dev-python/wcwidth[${PYTHON_USEDEP}]"
23 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 ${RDEPEND}
26                 $(python_gen_impl_dep 'sqlite')
27                 dev-python/colorclass[${PYTHON_USEDEP}]
28                 $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*')
29                 virtual/python-funcsigs[${PYTHON_USEDEP}]
30         )
31 "
32
33 PATCHES=(
34         "${FILESDIR}/tabulate-0.8.6-avoid-pandas-dep.patch"
35 )
36
37 distutils_enable_tests nose