dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-python / svgwrite / svgwrite-1.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python Package to write SVG files"
10 HOMEPAGE="https://github.com/mozman/svgwrite"
11 SRC_URI="https://github.com/mozman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND=">=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
22
23 PATCHES=(
24         "${FILESDIR}"/${P}-fix-tests-py38.patch
25 )
26
27 distutils_enable_tests pytest