dev-python/sunpy: use HTTPS
[gentoo.git] / dev-python / svg-path / svg-path-3.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
7
8 inherit distutils-r1
9
10 MY_PN="svg.path"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="SVG path objects and parser"
14 HOMEPAGE="https://github.com/regebro/svg.path"
15 SRC_URI="https://github.com/regebro/svg.path/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
23 RDEPEND="${DEPEND}"
24
25 S="${WORKDIR}/${MY_P}"
26
27 python_test() {
28         esetup.py test || die
29 }
30
31 python_install() {
32         python_domodule src/svg
33 }