0cfb52983d55f9c226c462c1ca466a75705676f4
[gentoo.git] / dev-python / sphinxcontrib-websupport / sphinxcontrib-websupport-1.0.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Sphinx websupport extension"
10 HOMEPAGE="http://www.sphinx-doc.org"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
16 IUSE="test"
17
18 RDEPEND="
19         >=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}]
20         >=dev-python/whoosh-2.0[${PYTHON_USEDEP}]
21         >=dev-python/six-1.5[${PYTHON_USEDEP}]
22         dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
23 # avoid circular dependency with sphinx
24 PDEPEND="
25         >=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}]"
26 DEPEND="
27         dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 ${RDEPEND}
30                 ${PDEPEND}
31                 dev-python/tox[${PYTHON_USEDEP}]
32                 dev-python/pytest[${PYTHON_USEDEP}]
33                 dev-python/mock[${PYTHON_USEDEP}]
34         )"
35
36 python_install_all() {
37         distutils-r1_python_install_all
38         find "${ED}" -name '*.pth' -delete || die
39 }
40
41 python_test() {
42         "${EPYTHON}" -m pytest tests/ || die "Tests fail with ${EPYTHON}"
43 }