dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / sphinxcontrib-spelling / sphinxcontrib-spelling-2.1.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Sphinx spelling extension"
10 HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD-2"
14 SLOT="0"
15 KEYWORDS="amd64 arm x86"
16 IUSE="doc test"
17
18 CDEPEND="
19         dev-python/pbr[${PYTHON_USEDEP}]
20         >=dev-python/pyenchant-1.6.5[${PYTHON_USEDEP}]
21         dev-python/six[${PYTHON_USEDEP}]
22         >=dev-python/sphinx-0.6[${PYTHON_USEDEP}]
23 "
24 DEPEND="
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
27         test? (
28                 ${CDEPEND}
29                 dev-python/nose[${PYTHON_USEDEP}]
30         )
31 "
32 RDEPEND="${CDEPEND}"
33
34 python_compile_all() {
35         use doc && emake -C docs html
36 }
37
38 python_test() {
39         nosetests || die "tests failed under ${EPYTHON}"
40 }
41
42 python_install_all() {
43         use doc && local HTML_DOCS=( docs/build/html/. )
44
45         distutils-r1_python_install_all
46 }