dev-cpp/gtest: mark s390 stable
[gentoo.git] / dev-python / spark-parser / spark-parser-1.8.5.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
6
7 inherit distutils-r1
8
9 MY_PN="spark_parser"
10
11 DESCRIPTION="An Early-Algorithm Context-free grammar Parser"
12 HOMEPAGE="https://github.com/rocky/python-spark/ https://pypi.org/project/spark_parser/"
13 SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19
20 RDEPEND=""
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 >=dev-python/nose-1.0[${PYTHON_USEDEP}]
25                 dev-python/mock[${PYTHON_USEDEP}]
26         )
27 "
28
29 S="${WORKDIR}/${MY_PN}-${PV}"
30
31 python_test() {
32         emake check
33 }