Merge branch 'dev-python/derpconf'
[wtk-overlay.git] / dev-python / south / south-0.7.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils
12
13 DESCRIPTION="Intelligent schema migrations for Django apps."
14 HOMEPAGE="http://south.aeracode.org/"
15 SRC_URI="http://www.aeracode.org/releases/${PN}/${P}.tar.gz"
16
17 LICENSE="Apache-2.0"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="doc"
21
22 RDEPEND="dev-python/django"
23 DEPEND="${RDEPEND}
24         dev-python/setuptools
25         doc? ( dev-python/sphinx )"
26
27 # I should leave a very angry comment here
28 S="${WORKDIR}/andrewgodwin-south-738417d7a8ab/"
29
30 src_compile() {
31         distutils_src_compile
32
33         if use doc ; then
34                 emake -C docs html || die "building docs failed"
35         fi
36 }
37
38 src_install() {
39         distutils_src_install
40
41         use doc && dohtml -r docs/_build/html/*
42 }
43
44 pkg_postinst() {
45         distutils_pkg_postinst
46         elog "In order to use the south schema migrations for your Django project,"
47         elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
48         elog "manage.py will now automagically offer the new functions."
49 }