dev-python/wsgiproxy2: Keyword 0.4.6-r1 ppc, #726188
[gentoo.git] / dev-python / soupsieve / soupsieve-2.0.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
11 HOMEPAGE="https://github.com/facelessuser/soupsieve
12         https://pypi.python.org/pypi/soupsieve"
13 SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
18 IUSE="test"
19 RESTRICT+=" !test? ( test )"
20
21 BDEPEND="${RDEPEND}
22         test? (
23                 dev-python/beautifulsoup[${PYTHON_USEDEP}]
24                 dev-python/lxml[${PYTHON_USEDEP}]
25                 dev-python/html5lib[${PYTHON_USEDEP}]
26         )
27 "
28
29 distutils_enable_tests pytest